@bmorel I've moved the most common and trivial renaming parts into a separate commit (the 2nd one).
The 1st commit now consists of the original fir…
RMLUI: fix Material Icons glyphs
RMLUI: rename custom RCSS property border-width
Yeah, part of my objection is the semantics are unclear from the name. But also it returns a different result from the original code, in the case o…
pm should be global either everywhere or nowhere.
This is not a good thing to make a member function. pml_t is a hodgepodge of variables which doesn't correspond to any coherent concept, so it is n…
Function names should begin with a capital letter
setFireBeam got into PM_ClimbMove PM_WalkMove dedup (to PmoveSingle) somehow
You don't have to fix it if you don't want to
PM_ClimbMove PM_WalkMove dedup (to PmoveSingle)
What's the meaning of this? I think "Slide" is just talking about that 1 if block.
This is something I had in previous betterai's BT, that I lost when I wanted to cleanup everything. Interestingly enough, a player noticed very qui…
@necessarily-equal @ing in case you want to investigate the reverted one
Revert "Convert mapRotations to BoundedVector and std::string"
Always used cached value of key catcher
Ones which don't directly relate to RmlUi migration.
Concerning the revert, it appears that it's the reason why packages does not work at all, even with custom maprotation file.
I do know know the rea…
Well, I'm fine with not merging it, or maybe only merge some. Namely:
fix virtual classes lacking virtual …
Hopefully the various teams using Crunch would be able to converge on a maintained fork at some point. I fear that mass reformatting commits would …
Removes a bunch of warnings from paranoid clang. Some stuff are left aside (Wcomma is unfinised) because they require more time to be analyzed (som…
Advanced DXTc texture compression and transcoding library with Unity improvements
Updated Jan 18
I see. Thanks for explanations.
The 1st commit I believe just contains the trivial find-and-replace stuff like Rocket -> Rml and CString -> c_str.
Nope, there's more than just t…
You can check out the rmlui3/sync branch on Daemon to get C++14 activated.
The 1st commit I believe just contains the trivial find-and-replace stuf…
It doesn't work with predictedPlayerState - it's all zero the first time this executes
Yeah that's what I did on my inactive ASAN branch. slipher@237ff1b
I do not know how CI passes, but here I can't compile at all, something unsets the -std=c++14 that I put in the CXXFLAGS, somewhere, somehow, and s…
I checked what CG_MyTeam() does, and it checks cg.predictedPlayerState.persistant[PERS_TEAM].
Why the change? (I don't say this is wrong, I focused…
Actually, there's an even better solution: to move the code which uses those parameters out of the function, since it's only used by BG_PlayerState…
I believe all comments have been addressed properly now, except for «This commit (PM_ContinueLegsAnim PM_StartLegsAnim dedup ) makes the code harde…
This makes me think that for ASAN we could simply encapsulate the whole block like this:
#if !defined(__has_feature) || !__has_feature(address_sani…
LGTM. I don't know the relations with NaCl, so like necessarily-equal I'll trust you on that point.
makes me thinking about 3 (not related to C++14) things:
there is no new / delete operators
builds don't pass when using USE_ADDRESS_SANITIZER
I'll trust you on that one
Will do that then.
Well, I had explanations since then about why crn is better than webp (uses less GPU memory, for reference), so I guess such a cmake could use crn …
Currently there are a couple of options:
Use Urcheon for a fancy build with crn compression, delta paks and so on
Idiot method - copy nexe's into …
Please squash last commit :)
How about instead of bool extrapolate, int time to have Util::optional<int> extrapolateFromTime? Then there aren't two bool arguments (confusing), …
bool extrapolate, int time
Personally I find it easier to follow when the original commit that had mistakes or improvements is modified to include the changes, rather than ha…
required for buildqueue
or using a script to place the buildables.
That's indeed a serious problem.
The other problems are existing ones but the change clearly could mak…
Allow immediate building placement but increase construction time of following buildings if build in quick succession.
Alien buildings are scaled b…
Ah, well, yes didn't noticed the *0, I was focused on the 0x12346.... silly me
Don't call IN_Restart in vid_restart
Remove silly NORETURN on /crash
Crashing of course :)
RMLUI: warn if it calls unimplemented transform
RMLUI: set RML in OnUpdate, not OnRender
Fun fact: there is no such entry.
@slipher : I addressed the comments, but to keep things easier to track, since have not merged them, instead I pushed more commits on top.
I suppose doing that (returning a ref instead of a pointer) should be addressed in a different PR (as this one is enormous enough as it is, and thi…
Mark functions override in cg_rocket_draw.cpp
Updated Jan 18
Note that this is based on a March 2020 version of RmlUi, so there is still a bit of migration to get up to the latest version.
wallwalking/sprinting hud cleanup
UI: allow different styles to show sprint status
RMLUI: fix image color syntax in hud_alien.rml and hud_human.rml
RMLUI: fix decorator syntax in hud_human.rml
Currently, to mod unvanquished, one needs several things:
to modify and build the C++ side, with $EDITOR, cmake, ninja or make or an IDE, a C++ co…
Also update the ckit option description to mention repairing?
From what I've seen, generating navmeshes accounting for the jump's height poses lot of problems on parpax (but again, with current navmesh generat…
Note that the screens here are on station15
Moving the code that sets point around won't make the code more efficient, and this is the part that is hard to read, so I'd rather have this chang…
Apparently this warning can't trigger without -O2. All of our builds are currently in Debug mode, so it can't be triggered.
By applying #1691 without last commit on master. Gcc version 10.2.1 from debian.
How do you even trigger this warning? I tried a bunch of different code samples and GCC versions and couldn't get it on any of them.
When I prepare AI experimental builds, I use the default build environment, and it happens that it just caught an error in one of my PRs (will fix …
This breaks the GUI, for some reason.
When opening a private chat with overmind, it is impossible to send it commands, like !list or list. This is useful for testing stuff without spamm…
explain what adv granger spit can do
maybe document what's this line is while you're at it?
I agree with slipher: the only reason I erroneously used Math::Clamp() without reading return value was because this is what unvanquished's API usu…
Understandable, but considering this is done a lot, I wanted to reduce the number of calculations. This commit have zero impact on the API though, …
true enough, will change that. It's just kind of an habit I've taken while reading bot code :)
When I get a pointer (and not a reference) from a function, I always consider things can go wrong and thus always put an assert after if I do not h…
Good catch, needs an additional "else" block there
Thanks, will update the comment.
I think you'll change your mind after some commits, since code surrounding PM_ContinueLegsAnim and PM_StartLegsAnim gets moved to be organised in a…
So this requires navgen changes?
Yes and no.
Of the 3 changes, only the crouching requires navmesh change. The lesser-autojump brings improvement…
improve doc on obstacle avoidance functions
Just some comments to help people understanding what's going on. Backported from my betterai work: I needed that to make the rewrite easier :)
This one PM_ClimbMove PM_WalkMove dedup (to PmoveSingle) is not correct because there were early returns from PM_WalkMove, but now the rest of the …
Useless assertion as BG_Class always returns something even if given an out-of-range value.
Nit: our style for variable names is wpAnim
In a .cpp file this should be static not inline
pm->ps is only 6 characters. There doesn't need to be a variable for it.
Commit PM_CorrectAllSolid cleanup definitely makes the code harder to read.
This commit (PM_ContinueLegsAnim PM_StartLegsAnim dedup ) makes the code harder to read IMO
PM_ContinueLegsAnim PM_StartLegsAnim dedup
Looks like 1 is toes in water, 3 is "eyes" in water (viewheight), and 2 is halfway between toes and eyes.
So this requires navgen changes? In that case the navgen changes should be in the same PR, as navgen now lives in the same repository.
I would rather keep a = Clamp(a,b,c). I think ClampArg just makes it harder to read.
Other commits look good.
a = Clamp(a,b,c)
I've been using TODO(0.53)
Actual testing seems to show that the code works fine.
About navmeshes, though, there is new data. To generate navmeshes which takes the most out o…